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1 Prerequisites

You should be using Eclipse 3.7 Indigo or Eclipse 3.6 Helios. You may check which version you have installed
by looking at the logo that appears during startup; it should say Eclipse Indigo or Eclipse Helios.

Note: Please note that the plug-in cannot be installed on an older version of Eclipse e.g. Eclipse 3.5
Galileo. It only works with Eclipse 3.7 Indigo or Eclipse 3.6 Helios. If you are using Eclipse Indigo or Helios
and are having problems please contact us.

2 Installing CodingSpectator

After installing Eclipse, you need to install our plug-in by following the steps below. The screenshots below
are taken from Eclipse Indigo but should look similar for Eclipse Helios:

1. In Eclipse, go to Help > Install New Software....

2. Click the Add button on the top right corner of the dialog.

3. Add a new update site. Set the Name field to CodingSpectator and the Location field to one of the
following depending on your version of Eclipse as shown in Figure 1.

• http://codingspectator.cs.illinois.edu/updates/indigo-sr1 (Eclipse 3.7.1 Indigo SR1)
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• http://codingspectator.cs.illinois.edu/updates/indigo (Eclipse 3.7.0 Indigo)

• http://codingspectator.cs.illinois.edu/updates/helios (Eclipse 3.6 Helios).

Then, click OK.

Figure 1: Add the update site of CodingSpectator.

4. After adding the update site of CodingSpectator, select the CodingSpectator features as shown in
Figure 2.
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Figure 2: Select all the features of CodingSpectator to install.

5. Click Next to proceed.

6. You will now be presented with the Install dialog window listing the items that will be installed.
You may examine this list if you wish. Click Next to proceed.

7. You will now be presented with the Review Licenses dialog window detailing the licenses of the
plug-ins that will be installed. Take a moment to review them, and if you agree, proceed by clicking
Finish.

8. Eclipse should open the dialog in Figure 3 asking you to confirm that you accept our certificate. In
the Do you trust these certificates, please select the check box. Click OK to continue.

Note: You need to select check box before clicking the OK button to accept our certificate. If you
click the OK button without selecting the check box on the dialog, Eclipse terminates the installation
of CodingSpectator silently.
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Figure 3: The dialog that asks if you trust the certificate of CodingSpectator.

9. If Eclipse cannot retrieve the installation files of CodingSpectator, it will open a dialog such as the
one shown in Figure 4 warning you that you are installing unsigned content. If you see this dialog,
it means that Eclipse has failed to install CodingSpectator correctly. Click OK to dismiss the dialog.
Then, uninstall CodingSpectator (See Section 9), and try to install it again. If the problem persists,
please contact us.

Figure 4: The dialog that warns about unsigned content implies that Eclipse has failed to install CodingSpec-
tator.

4



10. A dialog will pop-up asking you to restart Eclipse after the software updates. Click Restart Now.
Please do not use the other options on that dialog.

11. After restarting, you can check the About Eclipse dialog to see if CodingSpectatorhas been installed.
Click on Eclipse > About Eclipse... on OS X or Help > About Eclipse... on Linux and Win-
dows to display the dialog. You should see our CodingSpectatorlogo in that dialog as shown in Figure 5.

Figure 5: Upon successful installation, CodingSpectator displays its icon in the About dialog.

3 Using CodingSpectator

CodingSpectatoris a non-intrusive extension that monitors your coding activities inside Eclipse. Specifically,
it collects data about your use of the Java development tools in Eclipse. CodingSpectatorwill run in the
background and will not interfere with your coding routines except for the occasional dialog asking you to
upload your data. Your data will be uploaded to a secure server at the University of Illinois that only the
researchers have access to.

Note: Our plug-in will monitor for programming behavior in all workspaces that you create using that
particular Eclipse instance. As detailed on the consent form, the plug-in will record certain code development
activities that are performed in the workspace and store that information. In addition, the plug-in might
collect some code snippets to provide more context to the activities that are being performed.

If you have sensitive data that you do not wish the plug-in to collect, you would need to install two
instances of Eclipse: one with our plug-in and one without our plug-in. To help you easily identify a
workspace with CodingSpectator installed, we have also placed an icon in the status line of Eclipse as shown
Figure 6. If you wish, you may disable the icon by following the instructions in Section 7.

Please feel free to talk to us if you have any questions and concerns about your privacy. We can work
our a suitable compromise.
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Figure 6: An icon appears on the status line reminding users that CodingSpectator is installed.

4 Uploading the data automatically

Once a day (at most), during the initial startup of Eclipse, you might be presented with the dialog box
shown in Figure 7 asking you to upload your data. Please provide your CodingSpectator user name and
password when prompted. You should have received your username and password when you signed up for
our study.

Figure 7: The dialog that asks your CodingSpectator account information in order to upload your data to
CodingSpectator servers.

If you provide the wrong user name/password, our plug-in will prompt you again with the dialog in
Figure 8:
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Figure 8: This dialog shows up when the user name and password that you have entered are wrong.

If you forget your user name or password, please contact us to send them to you. You may also change
your password by visiting http://codingspectator.cs.illinois.edu/Accounts/.

5 Saving CodingSpectator password

If you wish Eclipse to remember your CodingSpectator password, click on the Save password (could

trigger secure storage) check box on the authentication dialog in Figure 8. This will make Eclipse
store your username and password using its underlying Secure Storage mechanism. If you decide to save
your password, it will proceed to ask you to create a master password. Please follow the instructions on the
screen as they depend on the operating system.

After you save your password, on subsequent uploads of CodingSpectator, you will no longer see the
dialog in Figure 7 but one of the dialogs in Figure 9 depending on your operating system.
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Figure 9: If you save your CodingSpectator account information in Eclipse, you will see one of these dialogs
at your future attempts to log into CodingSpectator.

If you save your CodingSpectator password on Linux, Eclipse will still prompt you for your master
password before every data upload. Please enter the master password that you have created (not your
CodingSpectator password) when prompted by the Secure Storage dialog box. On Mac OS X and Windows,
Eclipse uses the system-wide keyring and does not ask you for a master password. However, if you are using
Eclipse Helios on Windows 64 bits, then you would need to perform the following steps to prevent
Eclipse from prompting for your master password.

1. If your Eclipse is running, shut it down.

2. Download the deployable form of Windows 64 bits secure storage fragment for Eclipse Helios.

3. Copy the downloaded JAR file into the dropins folder of your Eclipse Helios installation. To check that
Eclipse has picked up the JAR file, go to Window > Preferences, type Secure Storage in the search
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box, and select General > Security > Secure Storage from the search results. Eclipse must now
list a new master password provider called Windows Integration (64 bits) as shown in Figure 10.

Figure 10: If you save your CodingSpectator password and Eclipse has a master password provider that
integrates with your operating system, Eclipse won’t prompt you for a master password before your data
uploads.

4. Start Eclipse.

5. If you have already stored CodingSpectator password before installing the master password provider
that integrates with Windows (and thus, were prompted for the master password every time you
uploaded CodingSpectator data), you will need to delete the corresponding entry in order to use the
installed master password provider for Windows. Go to Window > Preferences, type Secure Storage

in the search box, and select General > Security > Secure Storage from the search results. Open
the Contents tab and expand the [Default Secure Storage] item. If you have already saved your
CodingSpectator password, you should see an item for CodingSpectator as shown in Figure 11. Click on
the CodingSpectator item, then click the Delete button. Next, click the Yes button in the confirmation
dialog box.
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Figure 11: If Eclipse has already saved your CodingSpectator password you should delete the secure storage
of CodingSpectator in order to use the new master password provider that integrates with your operating
system.

6 Uploading the data manually

You may also trigger the data upload manually. We provide this facility because, occasionally, it might not
be convenient to upload the data during the startup of Eclipse.

To invoke the manual uploading of your data, you can go to Window > Preferences (on Linux and
Windows) or Eclipse > Preferences... (on Mac OS X). Click on the CodingSpectator> Display section
shown in Figure 12.
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Figure 12: CodingSpectator provides a preference page for manually updating your data.

In that particular preference pane, you will see:

1. the date and time of your last upload and

2. an Upload Now button that you can invoke to upload your data.

7 Showing or hiding CodingSpectator status line icon

To hide or show the CodingSpectator status line icon, you can go to Window > Preferences (on Linux
and Windows) or Eclipse > Preferences... (on Mac OS X). Click on the CodingSpectator> Display

section shown in Figure 13. Then check or uncheck the Show CodingSpectator in the status line check
box.

Note: Toggling the display of the icon does not disable CodingSpectator — it is still actively running
and collecting data in the background. There is currently no way to turn off CodingSpectator except by
uninstalling it (See Section 9).
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Figure 13: CodingSpectator provides a preference for manually updating your data.

8 Updating CodingSpectator

During this research study, we might require you to update CodingSpectator. Should this become necessary,
we will contact you via e-mail to upgrade the plug-in. This is a simple process that you can perform by
going to Help > Check for Updates (See Figure 14) in the Eclipse application.

Figure 14: Update CodingSpectator.
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9 Uninstalling CodingSpectator

1. You can uninstall our plug-in through the About Eclipse... dialog. You can invoke the dialog
shown in Figure 15 by going to Eclipse > About Eclipse... on Mac OS X or through Help >

About Eclipse... on Linux and Windows.

Figure 15: The “About Eclipse” dialog.

2. In dialog shown in Figure 15, click on the Installation Details button. As a result, the dialog
shown in Figure 16 should appear. The list of plug-ins installed might be different from the image
below depending on what other plug-ins you have installed.
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Figure 16: List of the software installed on Eclipse.

3. Click on CodingSpectator from the list to select it. Then click on the Uninstall... button.

4. Eclipse will calculate the dependencies and check the validity of uninstallation. After a while, it will
show the dialog shown in Figure 17.
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Figure 17: Review and confirm the uninstallation of CodingSpectator.

5. Click Finish

6. Eclipse will proceed to uninstall CodingSpectator. After a while, the dialog in Figure 18 will pop-up
asking if you would like to restart Eclipse for the changes to take effect. Click Restart Now.

Figure 18: Restart Eclipse to complete the installation of CodingSpectator.
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